Tethered iOS 5.1 Jailbreak For Non-A5 Devices Released By iPhone Dev-Team

iPhone Dev Team has released a tether jailbreak of iOS 5.1. But this tethered jailbreak is only for non-A5 devices. This means that the jailbreak won't work for iPhone 4S or iPad 2. If you own iPad or an iPhone device earlier than iPhone 4S, you may want to try your hands at it. However, if you haven't already moved to iOS 5.1, you must know that once you do, you may lose your jailbreak and then the best you can do is apply the tethered jailbreak which is detailed below.

Continue ReadingTethered iOS 5.1 Jailbreak For Non-A5 Devices Released By iPhone Dev-Team