Technological News Portal

Unlock iOS 4.3.1 on iPhone 4, 3GS With Ultrasn0w 1.2.1 [How To]

iPhone Dev-Team have just pushed UltraSn0w version 1.2.1 out to the public! This update does not add support for any new baseband versions it was updated simply so users on the iOS 4.3.1 firmware can use UltraSn0w to maintain their current unlock. Moreover this updated version of Ultrasn0w unlock fix signal bar issues on iOS 4.3.1 compatible iPhones, running on the old baseband.

How to Update iPhone 3GS to 06.15.00 Baseband for Unlock:

Ultrasn0w 1.2.x unlocking requires that your iPhone 3GS is jailbroken with 06.15.00 baseband. Follow the complete guide posted here (with PwnageTool) or here (for Redsn0w) to update your iPhone 3GS baseband to 06.15.00 and jailbreak it on iOS 4.1 / 4.2.1 before proceeding with the following steps.

Warning: Updating iPhone 3GS baseband to iPad’s 06.15.00 might result in loss of GPS functionality.

The Steps are as follows:

Step 1: First of all you will have to jailbreak your iPhone 4 or 3GS on iOS 4.3.1 and preserve the old baseband using either PwnageTool on Mac, or Sn0wbreeze on Windows. Instructions on how to jailbreak iOS 4.3.1 using PwnageTool can be found here, and for Sn0wbreeze can be found here.

Step 2: Once you are done with the jailbreak, you can now unlock your iPhone on the supported basebands using Ultrasn0w 1.2.1 from Cydia. To do this:

* Start “Cydia” on your iPhone.

* Touch on “Manage” tab on the bottom.

* Now touch on “Sources”

* Touch on “Edit” and then on “Add”. You will be prompted to enter a url source as seen in the screenshot below. Type “http://repo666.ultrasn0w.com” and touch on“Add Source” to add this repo if you haven’t already.

Cydia will now automatically update your sources by following a series of automated steps.

* After installation is completed. Search for “ultrasn0w 1.2.1” in Cydia and install this application. This app will automatically unlock your iPhone so that you can use it with any carrier.

Step 3: Now simply restart your iPhone and voila! you should now have a fully unlocked iPhone 4 or 3GS, running iOS 4.3.1 !

That’s it.

Thanks

[ttjad keyword=”iphone”]

You might also like
Why Not Join 250,000+ Readers, Like You!
AND GET OUR LATEST CONTENT IN YOUR INBOX

SUBSCRIBE 
Your information will never be shared
close-link